Вопрос по информатике:
Надо в Pascal составить программу. Помогите.
1) Задает следующие вопросы и позволяет ввести ответы:
Как тебя зовут?
Введи номер класса в котором ты учишься.
2) Выдает фразу :
Имя, закончишь школу в ...... году. Верно? Да/нет.
3) Позволяет ввести ответ и анализирует его:
Если ответ да, то выводит фразу: " Ай да я! Ай да молодец!"
Если ответ нет, то выводит фразу: " Ой! Неужели ошиблась?!"
Если ответ ни да, ни нет, то выводит фразу: " Хм! Вечный школьник?!"
- 17.12.2016 14:21
- Информатика
- remove_red_eye 4522
- thumb_up 20
Ответы и объяснения 1
Begin
var N,X: string;
var K,Y: integer;
var M: longint;
writeln ('Как тебя зовут? ');
readln(N);
writeln ('Введи номер класса в котором ты учишься. ');
readln(K); Y:=2016+1+11-K;
writeln (N,' закончишь школу в ',Y,' году. Верно? да/нет. ');
read(X);
if X='да'
then writeln ('Ай да я! Ай да молодец!')
else
if X = 'нет'
then writeln ('Ой! Неужели ошиблась?!')
else writeln ('Хм! Вечный школьник?!');
end.
- 18.12.2016 18:31
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.