Вопрос по информатике:
Программа должна вывести одно число: максимальное число, оканчивающиеся на 9.
Входные данные: Выходные данные:
3 19
9
19
23
- 26.06.2018 18:37
- Информатика
- remove_red_eye 19312
- thumb_up 39
Ответы и объяснения 1
Var
n, max, i, d: integer;
begin
readln(n);
max := 0;
for i := 1 to n do
begin
readln(d);
if (d mod 10 = 9) and ((max < d) or (max = 0)) then
max := d;
end;
writeln(max);
end.
- 27.06.2018 15:04
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.