Вопрос по информатике:
1)Напишите программу,в которой вводится символ,если он находится в интервале '0'. . . '9',то на экран выводится его код,в противном случае на экран выводятся следующие за ним 2 символа
2)Напишите программу,которая при вводе латинской прописной буквы выводит на экран такую же букву,но строчную
НА ПАСКАЛЕ!!!!!!!
- 18.10.2017 07:19
- Информатика
- remove_red_eye 12732
- thumb_up 16
Ответы и объяснения 1
//PascalABC.Net 3.1.0.1200
var
c: char;
begin
readln(c);
if c in ['0'..'9'] then
writeln(ord(c))
else
writeln(chr(ord(c) + 1), chr(ord(c) + 2));
if c in ['A'..'Z'] then
writeln(LowCase(c));
end.
- 19.10.2017 04:46
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.