Вопрос по информатике:
Напишите программу, которая считывает с клавиатуры n чисел и затем выводит на экран сумму и среднее арифметическое отрицательных чисел. в паскаль
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 11.10.2015 11:18
- Информатика
- remove_red_eye 15860
- thumb_up 37
Ответы и объяснения 1
Var i,n,nmb: integer;
dg,sm: real;
begin
sm:=0; nmb:=0;
write('n = ');
readln(n);
write('числа через пробел: ');
for i:=1 to n do
begin
read(dg);
if dg<0 then
begin
sm:=sm+dg;
nmb:=nmb+1;
end;
end;
writeln('сумма отрицательных чисел = ',sm);
writeln('среднее арифметическое = ',sm/nmb);
end.
- 12.10.2015 18:25
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.