Вопрос по информатике:
Написать программу для Pascal ABC:
Программа вводит 2 строки, затем из короткой строки вывод на экран символы, код которых больше 70, а из длинной строки – все цифры.
- 21.06.2015 03:47
- Информатика
- remove_red_eye 10515
- thumb_up 7
Ответы и объяснения 1
//PascalABC.NET 3.2 сборка 1318
Var
s1,s2,c:string;
i:integer;
begin
write('Type s1:');
readln(s1);
write('Type s2:');
readln(s2);
if length(s1)>length(s2) then
begin
for i:=1 to length(s1) do
if (s1[i]>='0') and (s1[i]<='9') then write(s1[i]);
writeln;
for i:=1 to length(s2) do
if ord(s2[i])>70 then write(s2[i]);
end
else
begin
for i:=1 to length(s1) do
if ord(s1[i])>70 then write(s1[i]);
writeln;
for i:=1 to length(s2) do
if (s2[i]>='0') and (s2[i]<='9') then write(s2[i]);
end;
end.
Пример ввода:
Type s1:Mi Zu
Type s2:MeL10N
Пример вывода:
MiZu
10
- 22.06.2015 19:43
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.