Вопрос по информатике:
Написать программу вычисления суммы кратных 5 из натурального ряда чисел от 1 до n, и произведение чисел кратных 3 (2 способа: for,while)
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 16.09.2018 19:55
- Информатика
- remove_red_eye 5917
- thumb_up 6
Ответы и объяснения 1
var
i, s, p :integer;
begin
write ('n=');
readln (n);
s:=0;
p:=1;
for i:=1 to n do
begin
if i mod 5=0 then s:=s+i;
if i mod 3=0 then p:=p*i
end;
Writeln ('s=', s, ' p=', p)
end.
2)
var
i, s, p :integer;
begin
write ('n=');
readln (n);
s:=0;
p:=1;
i:=1
while i<= n do
begin
if i mod 5=0 then s:=s+i;
if i mod 3=0 then p:=p*i;
i:=i +1;
end;
Writeln ('s=', s, ' p=', p)
end.
- 17.09.2018 15:14
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.