Вопрос по информатике:
Напишите программу для того чтобы протестировать детей как они умеют считать?Показывается пример они считают в паскале!
- 27.09.2018 20:19
- Информатика
- remove_red_eye 8633
- thumb_up 46
Ответы и объяснения 1
Var
n, i, r, sum, s: integer;
ms: array[1..100]of char;
begin
randomize;
n := random(3, 7);
var ar := arrrandom(n, 1, 50);
for i := 1 to n - 1 do
begin
r := random(1, 2);
if(r = 1) then ms[i] := '+'
else ms[i] := '-' end;
s := ar[0];
write(ar[0], ' ');
for i := 1 to n - 1 do
begin
write(ms[i], ' ', ar[i], ' ');
if(ms[i] = '+') then s := s + ar[i]
else s := s - ar[i];
end;
write(' = ');
read(sum);
if(s = sum)
then
write('Правильно')
else
write('Неправильно, правильный ответ : ', s);
end.
- 28.09.2018 07:29
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.