Вопрос по информатике:
Помогите, пожалуйста! Нужно написать программу, которая будет переводить из любой системы счисления в десятеричную. И должны присутствовать mod и div, желательно покороче!
- 05.09.2017 00:34
- Информатика
- remove_red_eye 13877
- thumb_up 35
Ответы и объяснения 1
Var
s:string;
m,pk:real;
a:array[1..20] of real;
i,k,n:integer;
begin
Write('Введите число в системе счисления с основанием [2;16]: ');
Readln(s);
n:=Length(s);
for i:=1 to n do begin
if s[i] in ['0'..'9'] then a[i]:=Ord(s[i])-Ord('0')
else
if s[i] in ['A'..'F'] then a[i]:=Ord(s[i])-Ord('A')+10
else
if s[i] in ['a'..'f'] then a[i]:=Ord(s[i])-Ord('a')+10
else begin
Writeln('Символ ',s[i],' недопустим!');
Exit
end
end;
Write('Введите основание системы счисления: '); Read(k);
if (k16) then begin
Writeln('Такое значение недопустимо!');
Exit
end;
m:=a[n];
pk:=k;
for i:=n-1 downto 1 do begin
m:=m+a[i]*pk;
pk:=pk*k
end;
Writeln('Десятичный эквивалент введенного числа равен ',m)
end.
Тестовое решение
Введите число в системе счисления с основанием [2;16]: 4e32Ca
Введите основание системы счисления: 16
Десятичный эквивалент введенного числа равен 5124810
- 05.09.2017 15:42
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.