Вопрос по информатике:
Помогите пожалуйста.
Составте программу в Паскаль к задаче.
Даны три натуральных числа. Напишите программу определяющую, существует ли треугольник с такими длинами сторон.
Если такой треугольник существует, то определите его тип (равносторонний, равнобедренный, равносторонний)
- 23.04.2018 02:55
- Информатика
- remove_red_eye 8901
- thumb_up 12
Ответы и объяснения 1
Var a,b,c:integer;
begin
Write('Введите сторону а: '); Readln(a);
Write('Введите сторону b: '); Readln(b);
Write('Введите сторону с: '); Readln(c);
if (a+b>c) and (a+c>b) and (b+c>a) then
begin
write('Данный треугольник существует и является: ');
if (a=b) and (b=c) then writeln('равносторонним');
if ((a=b) and (bc)) or ((a=c) and (cb)) or ((b=c) and (ac)) then writeln('равнобедренным');
if (ab) and (bc) and (ac) then writeln('разносторонним');
end
else write('Не существует');
end.
- 24.04.2018 04:03
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.