Вопрос по информатике:
Дан массив a состоящий из 30 целых чисел — рост 30 учеников школы. Сколько из них имеет рост больше 170 см? Можно ли сформировать баскетбольную команду (в команде должно быть не менее пяти человек ростом больше 170 см)?
Формат входных данных
На единственной строке через пробел записаны 30 целых чисел (100≤ai≤220)(100≤ai≤220) — росты учеников.
Формат выходных данных
Требуется в первой строке вывести единственное число — количество учеников, рост которых не меньше 170.
На следующей строке вывести «YES», если баскетбольную команду набрать можно, иначе вывести «NO».
- 12.04.2015 00:28
- Информатика
- remove_red_eye 8592
- thumb_up 7
Ответы и объяснения 2
//Так рост больше или не меньше 170? В данном решении рассматривается вариант с больше
//Dev-C++ 5.11 (C)
#include
int main(void)
{const int n=30;
int arr[n],k;
k=0;
for(int i=0;i
if(arr[i]>170)
k++;}
printf("%d \n",k);
if(k>=5)
printf("YES");
else
printf("NO");
return 0;}
- 13.04.2015 15:26
- thumb_up 20
Var
i, c: integer;
ar: array[1..30]of integer;
begin
c := 0;
for i := 1 to 30 do begin
read(ar[i]);
if (ar[i] > 170) then c := c + 1;
end;
writeln(c);
if(c >= 5) then write('YES')
else write('NO');
end.
- 14.04.2015 15:29
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.