Вопрос по информатике:
Даны оценки ученика по n предметам. Требуется определить общее количество пятерок и четверок.
Формат входных данных
На первой строке входного файла записано натуральное число nn (n≤100)(n≤100) — количество оценок. На следующей строке через пробел записаны оценки ученика — целые числа от 11 до 55.
Формат выходных данных
Требуется вывести искомое число.
Примеры
входные данные:
3
4 5 3
выходные данные:
2
- 15.09.2018 14:32
- Информатика
- remove_red_eye 17972
- thumb_up 31
Ответы и объяснения 2
//Dev-C++ 5.11 (C)
#include
int main(void)
{int arr[100],n,k;
scanf("%d",&n);
k=0;
for(int i=0;i
if(arr[i]==4
printf("%d",k);
return 0;}
- 16.09.2018 18:06
- thumb_up 13
Var
i, c, n: integer;
ar: array[1..10000]of integer;
begin
c := 0;
readln(n);
for i := 1 to n do
begin
read(ar[i]);
if (ar[i] = 4) or (ar[i] = 5) then c := c + 1;
end;
write(c);
end.
- 17.09.2018 16:22
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.