Вопрос по информатике:
Дан массив a из n
целых чисел. Требуется сначала вывести все четные элементы, затем — нечетные.
Формат входных данных
На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.
На следующей строке через пробел записаны целые числа ai
(∣∣ai∣∣≤103)
— элементы массива.
Формат выходных данных
Требуется в одной строке через пробел вывести элементы массива в заданном порядке.
- 25.07.2017 00:58
- Информатика
- remove_red_eye 19765
- thumb_up 22
Ответы и объяснения 1
Var
i, n: integer;
a: array[1..1000]of integer;
begin
readln(n);
for i := 1 to n do read(a[i]);
writeln;
for i := 1 to n do if (a[i] mod 2 = 0) then write(a[i], ' ');
for i := 1 to n do if (a[i] mod 2 0) then write(a[i], ' ');
end.
- 26.07.2017 04:18
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.