Вопрос по информатике:
Дан массив из n элементов. Необходимо определить, есть ли в данном массиве два соседних элемента, равных заданному числу k
? Если есть, то вывести индексы первой такой пары чисел. Индексация элементов начинаются с единицы
Формат входных данных
С клавиатуры вводится натуральное число n (n≤100). На следующей строке через пробел вводятся n элементов массива. Все числа по модулю не превосходят 100. В последней строке вводится число k, (−200≤k≤200).
Формат выходных данных
В качестве ответа выведите индексы искомых элементов через пробел в порядке возрастания. Если таких элементов нет, то вывести 0.
- 02.08.2018 17:31
- Информатика
- remove_red_eye 2083
- thumb_up 13
Ответы и объяснения 1
Var
i, k, n: integer;
a: array[1..10000]of integer;
begin
readln(n);
for i := 1 to n do read(a[i]);
readln(k);
for i := 2 to n do if(a[i - 1] = k) and (a[i] = k) then
begin
write(i, ' ', i - 1);
exit;
end;
write('0');
end.
- 03.08.2018 23:37
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.