Вопрос по информатике:
Вводя последовательно 10 чисел из интервала (-15;10), подсчитать кол-во положительных чисел и среднее арифметическое отрицательных чисел.
Помогите составить программу на pascal, пожалуйста :)
- 08.10.2015 09:18
- Информатика
- remove_red_eye 5744
- thumb_up 50
Ответы и объяснения 1
var
n,i,k, sum: integer;
a: array [1..10] of integer;
sr: real;
begin
sum:=0;
for i:=1 to 10 do
begin
read (a[i]);
if a[i]>0 then n:=n+1;
if a[i]<0 then
begin
sum:=sum+a[i];
k:=k+1;
end;
end;
sr:=sum/k;
writeln ('srednee=',sr);
writeln ('poloshitel=',n);
end.
- 09.10.2015 16:06
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.