Вопрос по информатике:
Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 0.Программа получает на вход натуральные числа, количество введеных чисел неизвестно,последовательность чисел заканчивается числом 0 (0-признак окончания ввода,не входит в последовательность)
- 19.01.2018 07:42
- Информатика
- remove_red_eye 1608
- thumb_up 49
Ответы и объяснения 1
Var
n, s: integer;
begin
s := 0;
repeat
readln(n);
if n mod 3 = 0 then s := s + n;
until n = 0;
writeln(s)
end.
- 20.01.2018 10:57
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.