Вопрос по информатике:
Напишите программу, которая находит в массиве количество элементов, равных максимальному.
Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести два числа, разделив их пробелом: максимальный элемент массива и количество элементов массива, равных максимальному.
Примеры
входные данные
6
1 2 3 2 3 3
выходные данные
3 3
пожалуйста на языке Pascal
- 01.02.2017 21:37
- Информатика
- remove_red_eye 1461
- thumb_up 9
Ответы и объяснения 1
Var arr: array[0..1000] of integer;
var n, i, max, max_num: integer;
begin
readln(n);
for i:= 0 to n do read(arr[i]);
max_num := 0;
max:= arr[0];
for i:= 1 to n do if arr[i] < max then max:= arr[i];
for i:=0 to n do if arr[i] = max then max_num:=max_num + 1 ;
writeln(max, ' ', max_num);
end.
- 02.02.2017 18:33
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.