Вопрос по информатике:
Составить программу, которая в последовательности из любых N целых чисел (до 100 чисел) считает количество чисел меньших среднего арифметического всех введенных чисел.
- 26.04.2018 06:43
- Информатика
- remove_red_eye 6108
- thumb_up 6
Ответы и объяснения 1
1. Путь решения
Поскольку среднее всех введенных чисел нельзя найти, пока не будет закончен ввод этих чисел, а затем каждое число нужно будет сравнивать с этим средним, введенные числа придется где-то хранить. Например, в массиве длиной 100 (в условии сказано, что количество чисел "до 100").
Считаем, что описан массив a[1..100] и в нем находятся n≤100 целых чисел (можно и нецелых, но раз ничего не сказано в условии, мы вправе решить это сами).
Тогда среднее определится по формуле:
а сумму мы умеем считать, накапливая значение в цикле со счетчиком, дающем проход по всем элементам массива.
Искомое количество чисел, меньших среднего - это тоже сумма, найти которую позволит еще один цикл, но в нем уже будет анализ условия.
2. Программа на языке Pascal
const
nn=100;
var
i,n,k,s:integer;
m:real;
a:array[1..nn] of integer;
begin
Write('Количество чисел равно '); Read(n);
Writeln('Введите числа:');
s:=0;
for i:=1 to n do begin Read(a[i]); s:=s+a[i] end;
m:=s/n;
k:=0;
for i:=1 to n do
if a[i]
end.
3. Пример работы программы
Количество чисел равно 10
Введите числа:
6 -4 11 -7 5 7 0 3 5 -2
Количество чисел, превышающих среднее значение, равно 4
- 27.04.2018 02:46
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.