Вопрос по информатике:
Составить программу, которая в последовательности из любых N целых чисел (до 100 чисел) считает количество чисел меньших среднего арифметического всех введенных чисел
- 26.02.2018 09:01
- Информатика
- remove_red_eye 19204
- thumb_up 19
Ответы и объяснения 1
//Dev-C++ 5.11(С)
#include
int main(void)
{int n,i,f;
float sr,ar[100];
scanf("%d",&n);
i=0;
f=0;
while(i
sr=sr+ar[i];
i++;}
sr=sr/n;
i=0;
while(i
printf("%d",f);
return 0;
}
Пример ввода:
5
1
2
3
4
5
Пример вывода:
2
- 27.02.2018 00:29
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.