Вопрос по информатике:
Входной замок Лисы Алисы работает следующим образом: если введено натуральное число, которое меньше 100 или больше 999 – на дисплее устройства появляется надпись «FALSE»; если у введённого числа сумма цифр равна 13 – появляется надпись «ENTER» и можно войти; в остальных случаях появляется надпись «LOCK».
Входные данные: натуральное число N ().
Выходные данные: необходимо вывести надпись, которая должна быть на дисплее.
Пример:
Ввод 2
Вывод FALSE
Ввод 427
Вывод ENTER
Ввод 318
Вывод LOCK
- 10.07.2018 10:05
- Информатика
- remove_red_eye 19053
- thumb_up 35
Ответы и объяснения 1
Var a,n,p,m:integer;
beginread(a);if (a99) then begin n:= a mod 10 ; a:= a div 10; p:= a mod 10; a:= a div 10; m:= a mod 10; if n+p+m=13 then writeln ('ENTER') else writeln ('LOCK');
end else writeln ('FALSE');
end.
- 11.07.2018 20:23
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.