Вопрос по информатике:
Требуется написать программу которая по числу n(1<n<10000000000) найдет максимальное число k такре что nделится на k квадрат
- 26.12.2017 20:16
- Информатика
- remove_red_eye 16139
- thumb_up 10
Ответы и объяснения 1
Unsigned long k = 10000000000;
for(k = 10000000000; k > 2; k--) if(n % (k*k) == 0) break;
printf(k);
- 27.12.2017 16:26
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.