Вопрос по информатике:
Напишите программу, которая меняет местами первую и последнюю цифру натурального трехзначного числа. (ABC Pascal)
- 23.07.2018 06:35
- Информатика
- remove_red_eye 6664
- thumb_up 8
Ответы и объяснения 1
Var
a,chislo,t:longint;
c,nov,posl:integer;
begin
readln(a);
posl:=a mod 10;
chislo:=a;
t:=1;
repeat
a:=a div 10;
t:=t*10;
until a<10;
chislo:=chislo mod t;
chislo:=posl*t+chislo-posl+a;
writeln(chislo);
readln;
end.
- 24.07.2018 11:50
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.