Вопрос по информатике:
Помогите написать программу с использованием с++ вводится кол-во чисел <100, а затем сами числа:1)вывести все числа которые больше ср.ар минимального и максимального числа. 2)вывести все числакоторые меньше ср.ар всех чисел. 3)вывести все числа которые кратны 5
- 07.10.2017 17:25
- Информатика
- remove_red_eye 12725
- thumb_up 45
Ответы и объяснения 1
#include
int main(){
int a[100],n,i,min,max,s;
scanf("%d",&n);
if(n > 0){
scanf("%d",&a[0]);
min = max = s = a[0];
}
for(i = 1; i < n; i++){
scanf("%d",&a[i]);
s += a[i];
if(a[i] < min) min = a[i];
if(a[i] > max) max = a[i];
}
printf("\n1: ");
for(i = 0; i < n; i++)
if(a[i]*2 > min + max)
printf("%d ",a[i]);
printf("\n2: ");
for(i = 0; i < n; i++)
if(a[i]*n < s)
printf("%d ",a[i]);
printf("\n3: ");
for(i = 0; i < n; i++)
if(a[i]%5 == 0)
printf("%d ",a[i]);
return 0;
}
- 08.10.2017 08:49
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.