Вопрос по информатике:
Дано трехзначное число. Напишите программу, которая определяет: является ли число "перевертышем", т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево. 123 - нет 121 - да 222 -да
- 05.10.2017 04:26
- Информатика
- remove_red_eye 14628
- thumb_up 23
Ответы и объяснения 2
Пусть число будет а1, а2, а3.
число а2 -нас не интересует, т.к. оно на месте справа - налево и наоборот.
Сл-но исследует а1 и а3
программа
берем а1
а1=а3 - если да , то число подходит -
если нет , число не подходит - переходим к следующему.
Вот и всё.
запишите этот алгоритм в предлагаемом Вам языке.
Успехов
- 06.10.2017 21:59
- thumb_up 25
Program prog;
Uses crt;
var a: integer;
begin
clrscr;
Write('Введите трехзначное число: ');
readln(a);
if (abs(a)>99) and (abs(a)<1000) then
if ((a mod 10)=(a div 100)) and (a>0) then
writeln('Перевертыш')
else
writeln('Не перевертыш')
else
writeln('Неверное число');
end.
- 07.10.2017 22:07
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.