Вопрос по информатике:
ПАСКАЛЬ!!. Известно, что первые два элемента массива равны a и b. А каждый следующий элемент равен сумме значений всех предыдущих элементов и собственного номера (нумерация элементов массива начинается с единицы). Заполните массив из n элементов, используя этот принцип и выведите значения элементов массива в обратном порядке.
Формат входных данных
Целые положительное число n (2
Целые числа a,b (-50 < a,b < 50)
Формат выходных данных
Строка, содержащая элементы искомого массива в обратном порядке, записанные через пробел
- 16.02.2018 21:39
- Информатика
- remove_red_eye 19534
- thumb_up 28
Ответы и объяснения 1
Const n=10;
var ar:array[1..n] of integer;
a,b,i,s:integer;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
ar[1]:=a; ar[2]:=b; s:=a+b;
for i:=3 to n do
begin
ar[i]:=s+i;
s:=s+ar[i];
end;
for i:=1 to n do write(ar[i],' ');
writeln;
end.
Пример:
a = 2
b = 3
2 3 8 17 35 71 143 287 575 1151
- 17.02.2018 22:19
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.