Вопрос по информатике:
Составьте программу, которая определяет, является ли сумма цифр введенного целого трёхзначного числа чётным числом
пример ввода:
567
пример ввода:
сумма цифр числа 567 - чётное число
- 06.07.2017 10:25
- Информатика
- remove_red_eye 1219
- thumb_up 38
Ответы и объяснения 1
Прошу заметить, что программа работает не только с трёхзначными числами. А работает и с тысячами, и с миллионами
program Znanija;
var n,a,i:integer;
begin
readln(n);
a:=n;
while(n > 0) do
begin;
i := i + 10 + n mod 10;
n := n div 10;
end;
if i mod 2 = 0 then
writeln('Сумма цифр числа ', a, ' - чётное число')
else
writeln('Сумма цифр числа ', a, ' - нечётное число');
end.
- 07.07.2017 02:30
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.