Вопрос по информатике:
Сложное задание по информатике:
Нужно написать программу на паскале, не используя if, then, else, с таким результатом:
Введите число
если число четное, то вывести 10;
если нечетное, то вывести -10
- 06.07.2015 17:39
- Информатика
- remove_red_eye 9345
- thumb_up 10
Ответы и объяснения 2
Var a:integer;
begin
write('a = ');
readln(a);
writeln(-20*(abs(a) mod 2)+10);
end.
Пример:
a = 28
10
- 07.07.2015 18:15
- thumb_up 4
Var
n: integer;
res: boolean;
begin
readln(n);
res:=odd(n);
case res of
true: writeln('-10');
false: writeln('10');
end;
end.
- 08.07.2015 15:18
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.