Вопрос по информатике:
Массив содержит четное количество элементов. напишите программу которая сортирует первую половину массива по возрастанию а вторую по убыванию. Каждый
элемент должен остаться в "своей" половине
C++ пожалуйста
- 25.12.2015 13:10
- Информатика
- remove_red_eye 16502
- thumb_up 25
Ответы и объяснения 1
#include
#include
#include
bool ToLess(int a, int b) {
return a > b;
}
int main() {
int count;
std::cin >> count;
std::vector vectorOfNombers(count);
for (size_t i = 0; i != count; ++i) {
std::cin >> vectorOfNombers[i];
}
sort(vectorOfNombers.begin(), vectorOfNombers.begin() + count / 2 - 1); sort(vectorOfNombers.begin() + count / 2, vectorOfNombers.end(), ToLess);
for (size_t i = 0; i != count; ++i) {
std::cout << vectorOfNombers[i] << " ";
}
}
- 26.12.2015 16:57
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.