Вопрос по информатике:
написать программу ...Пользователь вводит две стороны прямоугольника (целые числа). Определить радиус окружности (с точностью до четырех знаков после запятой), описать около него и его периметр. Сколько окружностей можно нанизать на нитку, с длинной, ровной периметру прямоугольника.
- 01.05.2016 01:38
- Информатика
- remove_red_eye 13525
- thumb_up 7
Ответы и объяснения 1
Из условий я не понял про нанизывание на нитку окружностей. Остальное сделал на языке Паскаль. На своём компьютере не проверял, т.к. данный язык у меня не установлен. На фото я укзал рисунок моего понимания условий задачи.
- - - - - - - - - - - - -- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
var
a,b : integer; {описываем длины сторон}
r,p : real; {описываем радиус и периметр}
begin
write ('Введите длину первой стороны прямоугольника: ');
readln(a);
write ('Введите длину второй стороны прямоугольника: ');
readln(b);
r:=(sqrt(a*a+b*b))/2; {находим радиус}
r:=trunc(r*10000)/10000; {округляем до четырёх знаков после запятой}
p:=(a+b)*2; {находим периметр прямоугольника};
writeln('Радиус окружности равен: ',r);
writeln('Периметр прямоугольника равен: ',p);
end.
- 02.05.2016 09:42
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.