Вопрос по информатике:
Напишите программу которая вычисляет периметр и площадь треугольника
- 23.08.2018 03:44
- Информатика
- remove_red_eye 7675
- thumb_up 39
Ответы и объяснения 1
{ Треугольник задан координатами вершин (x1;y1),(x2;y2),(x3;y3).
Найти площадь треугольника (используя формулу Герона) }
uses crt;
var x1,x2,x3,y1,y2,y3,a,b,c,s,p : real;
begin
clrscr;
write('x1=');readln(x1);
write('y1=');readln(y1);
write('x2=');readln(x2);
write('y2=');readln(y2);
write('x3=');readln(x3);
write('y3=');readln(y3);
a:=sqrt(sqr(x1-x2)+sqr(y1-y2));
b:=sqrt(sqr(x2-x3)+sqr(y2-y3));
c:=sqrt(sqr(x3-x1)+sqr(y1-y3));
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
write('s=',s);
readln;
end.
формула герона!
А так я думаю эти задачки очень даже не сложные, только формулы надо знать!! !
периметр- это сумма всех сторон
например
begin
writteln( 'введите 3 стороны' ) ;
readln(a,b,c);
writeln(' периметр = ',a+b+c);
readln;
end.
Вот и все!! !
Удачи!
- 24.08.2018 22:05
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.