Вопрос по информатике:
Напишите программу, которая заполняет массив из N = 10 случайными числами в диапазоне [-10,10], выводит его на экран, а затем находит индекс последнего элемента, равного введённому числу X. Программа должна вывести ответ «не найден», если в массиве таких элементов нет.
- 02.07.2018 08:54
- Информатика
- remove_red_eye 19801
- thumb_up 43
Ответы и объяснения 1
На C#
int n = 10;
int x = Convert.ToInt32(Console.ReadLine());
int [] mass = new int [n];
Random rnd = new Random();
for(int i = 0; i < mass.Length(); i++)
{
mass[i] = rnd.Next(-10, 9);
Console.WriteLine("mass[i] + " ");
}
if (mass[i] == x)
{
int index = i;
Console.WriteLine("Индекс элемента = " + index);
}
else Console.WriteLine("не найден");
- 03.07.2018 12:06
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.