Вопрос по информатике:
Купец привез на рынок рулон сукна длиной N вершков, но для уплаты пошлины ему нужно указать длину сукна в саженях, аршинах, пядях и вершках. Помогите ему – переведите длину сукна, записанного в вершках в сажени, аршины, пяди и вершки.
Программа получает на вход одно натуральное число N, не превосходящее 2109, – длину сукна в вершках.
Программа должна вывести 4 целых неотрицательных числа S, A, P, V – количество саженей, аршин, пядей и вершков, в сумме дающих ровно N вершков, при этом значение A должно быть меньше 3 (т. к. 3 аршина дают одну сажень), значение P должно быть меньше 4 (четыре пяди дают один аршин), значение V должно быть меньше 4 (четыре вершка дают одну пядь).
- 19.01.2018 07:11
- Информатика
- remove_red_eye 5717
- thumb_up 13
Ответы и объяснения 1
Var n, s, a, p, v:integer;
begin
write('N = '); readln(n);
s:=n div (3*4*4);
a:=(n mod (3*4*4)) div (4*4);
p:=(n mod (4*4)) div 4;
v:=n mod 4;
writeln('s = ',s,' a = ',a,' p = ',p,' v = ',v);
end.
Пример:
N = 2061
s = 42 a = 2 p = 3 v = 1
- 20.01.2018 14:26
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.