Вопрос по информатике:
9 КЛАСС Напишите программу в паскале/делфи (без разницы) подсчета суммы:
1)1/2+(1*2)/4+(1*2*3)/6+ и т.д
2)(x-4)/4^1 + (x+8)/8^2 + (x-12)/12^3 + и т.д
3)4/2+8/2^2+16/2^3+ и т.д
- 07.09.2017 06:50
- Информатика
- remove_red_eye 19897
- thumb_up 16
Ответы и объяснения 1
Var
i, n, temp: integer;
s, x: real;
begin
read(n, x);
s := 0;
temp := 1;
for i := 1 to n do
begin
temp := temp * i;
s := s + temp / (2 * i);
end;
writeln(s);
s := 0;
temp := 1;
for i := 1 to n do
begin
temp := temp * (-1);
s := s + (x + temp * 4 * i) / exp(i * ln(4 * i));
end;
writeln(s);
s := 0;
for i := 1 to n do
begin
s := s + 2;
end;
writeln(s);
end.
- 08.09.2017 21:24
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.