Вопрос по информатике:
У скольких натуральных чисел от 1 до 2 в степени 10 сумма цифр кратна четырем?
- 12.09.2017 17:04
- Информатика
- remove_red_eye 4114
- thumb_up 49
Ответы и объяснения 1
Задачу можно решать различными способами. Можно рассуждениями-вычислениями, а можно просто написать программу, в которой вычисляется нужное значение:
var i,a,s,k:integer;
begin
k:=0;
for i:=1 to 1024 do
begin
a:=i; s:=0;
while a0 do
begin s:=s+a mod 10; a:=a div 10; end;
if s mod 4 = 0 then k:=k+1;
end;
writeln('k = ',k);
end.
Результат:
k = 253
- 13.09.2017 19:16
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.