Вопрос по информатике:
Напишите программу на языке паскаль.богатый и бедный заключили спор .богатый отдает каждый день 100 в течение месяца .бедный отдает в первый день копейку каждый следующий день в 2 раза больше в течение месяца ,кто выграет спор
- 16.06.2015 14:23
- Информатика
- remove_red_eye 18147
- thumb_up 7
Ответы и объяснения 1
Var m1,m2,st,i:integer;
begin
m1:=0; m2:=0;
st:=1;
for i:=1 to 30 do
begin
m1:=m1+100;
m2:=m2+st;
st:=st*2;
end;
writeln('Богатый: ',m1,' бедный: ',m2);
if m1
end.
Результат:
Богатый: 3000 бедный: 1073741823
Выиграл богатый
- 17.06.2015 02:25
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.