Вопрос по информатике:
Помогите
написал прогу, но сайт не принимает решение. В чем ошибка? И можно ли по-другому составить программу?
Нужно было найти второй максимальный элемент
Последовательность состоит из различных натуральных чисел и завершается числом 0. Определите значение второго по величине элемента в этой последовательности.
Числа, следующие за числом 0, считывать не нужно.
program r1;
var max1,max2,k:longint;
begin
readln (k);
max1:=k;
max2:=k;
while k<>0 do begin
readln (k);
if k>max1 then begin
max2:=max1;
max1:=k;
end;
end;
writeln (max2);
readln;
end.
- 04.06.2015 11:38
- Информатика
- remove_red_eye 5377
- thumb_up 27
Ответы и объяснения 1
Пробуй через массив, это куда эффективней, и почитай про сортировки массива (в частности метод пузырька), удачи с:
- 05.06.2015 01:10
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.