Вопрос по информатике:
Элемент последовательности называется локальным максимумом, если он строго больше предыдущего и последующего элемента последовательности. Первый и последний элемент последовательности не являются локальными максимумами.
Дана последовательность натуральных чисел, завершающаяся числом 0. Определите количество строгих локальных максимумов в этой последовательности.
Формат входных данных:
Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит, а служит как признак ее окончания).
Формат выходных данных:
Выведите ответ на задачу.
Язык C++
- 05.08.2018 20:46
- Информатика
- remove_red_eye 11473
- thumb_up 42
Ответы и объяснения 1
#include #include #include
int main(void){ std::vector V; std::copy (std::istream_iterator(std::cin), std::istream_iterator(), std::back_inserter(V)); int count = 0; for (std::vector::iterator it = V.begin() + 1; it + 1 != V.end(); it++) if ( *it > *(it - 1) && *it > *(it + 1)) count++; std::cout << count << std::endl; return 0;}
- 06.08.2018 10:59
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.