Вопрос по информатике:
Помогите c С#! На основании алгоритмов напишите программу поиска максимального элемента в массиве из 10 элементов.
- 06.03.2015 01:22
- Информатика
- remove_red_eye 4632
- thumb_up 40
Ответы и объяснения 1
Using System;
class Program
{
static void Main(string[] args)
{
int n=10;
int[] a = new int[n];
int max;
Random r = new Random();
Console.WriteLine("Массив a:");
for (int i = 0; i < n; i++)
{
a[i] = r.Next(41)-20;
Console.Write("{0,5}", a[i]);
}
Console.WriteLine();
max = a[0];
for (int i = 1; i < n; i++)
if (a[i]>max) max = a[i];
Console.Write("max = {0}", max);
Console.ReadKey();
}
}
Пример:
Массив a:
3 7 17 -11 9 20 7 3 -15 10
max = 20
- 07.03.2015 00:43
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.