Вопрос по информатике:
По данному числу N распечатайте все целые степени двойки, не превосходящие N, в порядке возрастания.
Операцией возведения в степень пользоваться нельзя!
Входные данные
Вводится натуральное число.
Выходные данные
Выведите ответ на задачу.
Примеры
входные данные
50
выходные данные
1 2 4 8 16 32
- 25.10.2017 06:36
- Информатика
- remove_red_eye 12321
- thumb_up 20
Ответы и объяснения 2
Var n,st:integer;
begin
write('n = '); readln(n);
st:=1;
while st<=n do
begin
write(st,' ');
st:=st*2;
end;
writeln;
end.
Пример:
n = 50
1 2 4 8 16 32
- 26.10.2017 03:59
- thumb_up 15
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
var n:=ReadInteger;
1.Iterate(k->2*k).TakeWhile(x->x<=n).Println;
end.
Тестовое решение
50
1 2 4 8 16 32
- 27.10.2017 23:12
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.