Вопрос по информатике:
Помогите пож . Составить программу, запрашивающую у пользователя дату в кратком формате дд.мм.гг (например: 15.10.2012), и отображающую эту дату в полном формате (например: 15 октября 2012 года).
- 01.01.2018 12:01
- Информатика
- remove_red_eye 14372
- thumb_up 33
Ответы и объяснения 1
//Pascal ABC.NET 3.1 сборка 1256
Var
ars:array[1..12] of string:=('января','февраля','марта','апреля','мая','июня','июля','августа','сентября','октября','ноября','декабря');
s:string;
begin
read(s);
if s[1]='0' then delete(s,1,1);
write(copy(s,1,pos('.',s)-1),' ');
delete(s,1,pos('.',s));
write(ars[strtoint(copy(s,1,pos('.',s)-1))],' ');
delete(s,1,pos('.',s));
write(s,' года');
end.
Пример ввода:
15.10.2012
Пример вывода:
15 октября 2012 года
- 02.01.2018 21:18
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.