Вопрос по информатике:
Дано четырехзначное число. Определите, является ли его десятичная запись симметричной. Если число симметричное, то выведите 1, иначе выведите любое другое целое число. Число может иметь меньше четырех знаков, тогда нужно считать, что его десятичная запись дополняется слева незначащими нулями.
При решении этой задачи нельзя пользоваться условной инструкцией if и циклами
Входные данные
Вводится четырехзначное число.
Выходные данные
Выведите ответ на задачу.
Примеры
входные данные
2002
выходные данные
1
входные данные
2008
выходные данные
37
Заранее спасибо.
- 09.06.2018 01:34
- Информатика
- remove_red_eye 11565
- thumb_up 25
Ответы и объяснения 2
#include using namespace std; int main() { int n; cin >> n; cout << (((n / 1000) - (n % 10)) * ((n / 1000) - (n % 10))) + (((n / 100 % 10) - (n / 10 % 10)) * ((n / 100 % 10) - (n / 10 % 10)))+ 1; return 0; }
- 01.01.1970 00:00
- thumb_up 15
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
var s:=ReadlnString('n=');
s:=('0'*(4-s.Length)+s);
Writeln(Ord(s[:3].ToInteger=s[3:].Inverse.ToInteger));
end.
- 01.01.1970 00:00
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.