Вопрос по информатике:
Даны два натуральных числа n и m. Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число.
При решении этой задачи нельзя пользоваться условной инструкцией if и циклами.
Входные данные
Вводятся два натуральных числа n и m.
Выходные данные
Выведите ответ на задачу.
Примеры
входные данные
2
8
выходные данные
1
входные данные
8
2
выходные данные
1
- 03.03.2018 07:51
- Информатика
- remove_red_eye 15354
- thumb_up 45
Ответы и объяснения 1
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
var m,n:integer;
Write('Введите два натуральных числа через пробел: ');
Read(n,m);
Writeln(Ord((n mod m = 0) or (m mod n = 0)));
end.
- 04.03.2018 18:38
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.