Вопрос по информатике:
Длина Московской кольцевой автомобильной дороги —109 километров. Байкер Вася стартует с нулевого километра МКАД и едет со скоростью v километров в час. На какой отметке он остановится через t часов?
Входные данные
Программа получает на вход значения v и t. Если v>0, то Вася движется в положительном направлении по МКАД, если же значение v<0, то в отрицательном.
Выходные данные
Программа должна вывести целое число от 0 до 108 — номер отметки, на которой остановится Вася.
Примеры
входные данные
60
2
выходные данные
11
входные данные
-1
1
выходные данные
108
Заранее спасибо.
- 22.06.2015 16:05
- Информатика
- remove_red_eye 13292
- thumb_up 29
Ответы и объяснения 1
//Pascal ABC.NET 3.1 сборка 1256
Var
t,v,r:integer;
begin
read(t,v);
r:=t*v;
if r>0 then writeln(r mod 109) else
if 109-(abs(r) mod 109)=109 then writeln('0') else writeln(109-(abs(r) mod 109));
end.
Пример ввода:
80
2
Пример вывода:
51
- 23.06.2015 04:21
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.