Вопрос по информатике:
Написать программу, создающую одномерный массив из 15 элементов. Значения членов массива вводятся при выполнении программы. Программа должна находить минимальный и максимальный члены массива и их номера.
- 01.09.2017 12:30
- Информатика
- remove_red_eye 11365
- thumb_up 31
Ответы и объяснения 2
Var mas: array[1..15] of integer;
i, min, max, nMin, nMax:integer;
begin
writeln('Введите 15 элементов массива');
for i := 1 to 15 do
readln(mas[i]);
min := mas[1];
max := mas[1];
nMin := 1;
nMax := 1;
for i := 1 to 15 do
begin
if max < mas[i] then
begin
max := mas[i];
nMax := i;
end;
if min > mas[i] then
begin
min := mas[i];
nMin := i;
end;
end;
writeln('Максимальное число и его номер ', max, ' ', nMax, ' Минимальное число и его номер ', min, ' ', nMin);
end.
- 02.09.2017 22:12
- thumb_up 14
//Pascal ABC.NET 3.1 сборка 1256
begin
var ar:=ReadArrInteger(15);
writeln('Max:',ar.Max);
writeln('Max index:',ar.IndexMax+1);
writeln('Min:',ar.Min);
writeln('Min index:',ar.IndexMin+1);
end.
- 03.09.2017 07:40
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.