Вопрос по информатике:
Составить программу, которая бы запрашивала Хнач и Хкон и определяла произведение всех положительных чисел от Хнач до Хкон (решить задачу, используя цикл с предусловием – While .. Do). Пож помогите
- 20.09.2017 07:33
- Информатика
- remove_red_eye 11838
- thumb_up 49
Ответы и объяснения 1
//Pascal WDE
Var
xk,xn:real;
i,r,xik,xin:integer;
b:boolean;
begin
b:=false;
r:=1;
read(xn,xk);
xin:=round(xn-frac(xn));
xik:=round(xk-frac(xk));
i:=xin;
while i<=xik do
begin
if i>0 then
begin
r:=r*i;
b:=true;
end;
inc(i);
end;
if b=true then write(r) else write('0');
end.
Пример ввода:
-2.8
3.8
Пример вывода:
6
- 21.09.2017 18:00
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.