Вопрос по информатике:
Задание 4
Написать программу, создающую одномерный массив из 15 элементов. Значения членов массива вводятся при выполнении программы. Программа должна находить минимальный и максимальный члены массива и их номера.
- 23.11.2017 07:18
- Информатика
- remove_red_eye 4279
- thumb_up 39
Ответы и объяснения 2
Var a: array[1..15] of integer;
i, imin, imax: integer;
begin
imax:=1;
imin:=1;
for i:=1 to 15 do
begin
readln(a[i]);
if a[i] if a[i]>a[imax] then imax:=i;
end;
writeln('Минимальный член массива ', a[imin], ', его номер ', imin);
writeln('Максимальный член массива ', a[imax], ', его номер ', imax);
end.
- 24.11.2017 12:16
- thumb_up 5
Программа на Паскаль.
Program Dik;
Var
i, min, max, minnum, maxnum: integer;
a: array[1..15] of integer;
Begin
for i:= 1 to 15 do
readln(a[i]);
max:=a[1]; min:=a[1];
for i:= 1 to 15 do begin
if a[i]
end;
if a[i]>max then begin
max:=a[i]; maxnum:=i;
end;
end;
writeln('max=', max);
writeln('min=', min);
writeln('maxnum=', maxnum);
writeln('minnum=', minnum);
end.
- 25.11.2017 07:59
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.