Вопрос по информатике:
Чиновник, ежемесячно берёт взятки в размере Х рублей. Величина Х непостоянная и колеблется от 0 до 150000 рублей. X задаётся генератором псевдослучайных чисел. Автомобиль BMW 3, который хочет купить на взятки чиновник, стоит 1700000 рублей. Напишите программу, которая вычислит, сколько месяцев потребуется чиновнику на сбор нужной суммы.
- 01.10.2017 18:47
- Информатика
- remove_red_eye 15543
- thumb_up 37
Ответы и объяснения 1
//Pascal ABC.NET 3.1 сборка 1256
Var
x,s,i:integer;
begin
randomize;
s:=0;
i:=0;
while s<1700000 do
begin
inc(i);
x:=random(150001);
s:=s+x;
writeln('Месяц:',i,', своровал:',x,', сумма на текущий момент:',s);
end;
writeln('Res=',i);
end.
- 02.10.2017 17:33
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.