Вопрос по информатике:
Нужно написать программу на delphi:
вводится кол-во переменных с клавиатуры
на выходе 2 числа: сумма чисел, произведение квадратов.
То есть
"Введите кол-во переменных"
2
3
3
Сумма = 6
Произведение квадратов = 81
- 26.11.2017 13:25
- Информатика
- remove_red_eye 15403
- thumb_up 16
Ответы и объяснения 1
Консольное приложение:
program Pr1;
{$APPTYPE CONSOLE}
var
N, a, i, s: integer;
p: double;
begin
WriteLn('Введите кол-во переменных ');
ReadLn(N);
s:=0;
p:=1;
for i:=1 to N do begin
ReadLn(a);
s:=s+a;
p:=p*a*a;
end;
WriteLn( 'Сумма = ',s);
WriteLn('Произведение квадратов = ',p);
ReadLn;
end.
Пример:
Введите кол-во переменных
5
4
6
2
7
3
Сумма = 22
Произведение квадратов = 1016064
- 27.11.2017 15:32
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.