Вопрос по информатике:
Составить программу на паскале. Сформировать двумерный массив, состоящий из положительных и потрицательных элементов.Заменить положительные элементы-еденицей, а отрицательные-нулем
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 01.04.2017 11:13
- Информатика
- remove_red_eye 9644
- thumb_up 12
Ответы и объяснения 1
//Pascal ABC.NET 3.1 сборка 1219
Const
n=3;
Var
ma:array[1..n,1..n] of integer;
i,j:integer;
begin
randomize;
writeln('Matrix:');
for i:=1 to n do
begin
for j:=1 to n do
begin
ma[i,j]:=random(-10,10);
write(ma[i,j]:4);
if ma[i,j]>0 then ma[i,j]:=1 else ma[i,j]:=0;
end;
writeln;
end;
writeln('Final matrix:');
for i:=1 to n do
begin
for j:=1 to n do
write(ma[i,j]:4);
writeln;
end;
end.
Пример работы программы:
Matrix:
-6 1 8
1 -8 5
6 9 6
Final matrix:
0 1 1
1 0 1
1 1 1
- 02.04.2017 14:53
- thumb_up 26
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.