Вопрос по информатике:
Найти сумму положительных элементов вектора C[15].
Помогите составить программу в pascalabc
- 10.04.2018 00:18
- Информатика
- remove_red_eye 3559
- thumb_up 44
Ответы и объяснения 1
//Проверил. Да, равно.
//Pascal ABC.NET 3.1 сборка 1219
Const
n=15;
Var
ar:array[1..n] of integer;
i,s:integer;
begin
randomize;
writeln('Array:');
for i:=1 to n do
begin
ar[i]:=random(-10,10);
write(ar[i]:4);
if ar[i]>0 then s:=s+ar[i];
end;
writeln;
write('Result:',s);
end.
Пример работы программы:
Array:
3 -7 0 9 -9 6 -1 0 1 0 -7 9 -9 -5 -8
Result:28
- 11.04.2018 01:14
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.