Вопрос по информатике:
Задача в delphi. Составить программу для нахождения суммы: 2!+3!+4!+...+N!
- 21.09.2017 12:12
- Информатика
- remove_red_eye 4300
- thumb_up 29
Ответы и объяснения 1
//Создать консольное приложение
program ConsoleProgram;
{$APPTYPE CONSOLE}
var valueN,sum,i,i2,tmp:longint;
begin
sum:=0;
readln(valueN);
for i:=1 to valueN do
begin
tmp:=1;
for i2:=1 to i do
tmp:=tmp*i2;
sum:=sum+tmp;
end;
writeln(sum);
readln;
end.
- 22.09.2017 02:18
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.